Exporting data never finishes
Incident Report for HOALife
Resolved
This incident has been resolved.
Posted Mar 17, 2020 - 17:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2020 - 16:42 UTC
Investigating
We're investigating an issue where generating downloads may not complete.
Posted Mar 17, 2020 - 16:30 UTC
This incident affected: Inspection Dashboard.