Inspector App - Android - displaying map only
Incident Report for HOALife
Postmortem

The cause:

An update to Google Chrome changed the display characteristics for the map displayed in the Android Inspector App UI. Because our automated testing suite that runs daily is slow receive Google Chrome updates, the bug slipped through to customers who's Google Chrome app updated quickly. iOS/iPhone/iPad, Safari, and Firefox users were not impacted.

The fix:

A simple modification to the way the map display characteristics such that it doesn't overtake the property list.

Going forward:

While these types of changes are often out of our control there are ways that we can improve identifying these problems before they impact our users. Going forward we will ensure our automated testing suite tests against the very latest version of Google Chrome. Secondly, we will test against per-releases of Google Chrome as well to identify these issues before they impact our users.

Posted Jun 22, 2019 - 11:39 MDT

Resolved
We've implemented a fix and deployed it to production. We have confirmed the fix has resolved the issue on impacted devices. If you are using an impacted Android device, ensure you've restarted your Inspector App to get the latest assets.
Posted Jun 22, 2019 - 11:37 MDT
Identified
The issue has been tracked down to a recent update of Google Chrome, which is used to display the Android UI. We are working on a fix.

The issue only impacts the display when viewing the phone vertically. Rotating the phone to landscape mode displays the property list appropriately.
Posted Jun 22, 2019 - 10:49 MDT
Update
The issue seems to impact only certain versions of Android v9. We're investigating and will implement a fix.

The Inspector App for iOS/iPhone is unaffected.
Posted Jun 21, 2019 - 15:02 MDT
Investigating
Certain Android phones are displaying only the map when inspecting an association.
Posted Jun 21, 2019 - 15:01 MDT
This incident affected: Inspector App.