Inspection Finalization Issue on iOS 26.5.2

Incident Report for HOALife

Resolved

Resolved: Inspection Finalization Issue on iOS 26.5.2

This issue has been resolved, and a fix has been deployed.

If you were affected, please log out of the app and then log back in for the changes to take effect.
Posted Jul 16, 2026 - 11:12 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 16, 2026 - 10:18 MDT

Investigating

Inspection Finalization Issue on iOS 26.5.2

We are investigating an intermittent issue affecting the finalization of inspections on devices running iOS 26.5.2. Some inspections are not finalizing successfully or uploading from the device to the Dashboard.

The issue currently appears to be limited to devices running this iOS version. Early indications suggest that inspections containing photos with annotations may be preventing uploads from completing.

Recommended workaround: If possible, delay upgrading to iOS 26.5.2. If your device has already been upgraded, avoid adding annotations to inspection photos until the issue is resolved.

We will provide additional updates as more information becomes available.
Posted Jul 16, 2026 - 09:11 MDT
This incident affected: Inspector App.