Unable to add pictures to violation
Incident Report for HOALife
Resolved
The issue has been identified and a fix is in place. A phone restart may be required to resolved the issue.
Posted Feb 16, 2021 - 14:28 UTC
Investigating
We are currently investigating this issue.
Posted Feb 16, 2021 - 13:47 UTC
This incident affected: Inspector App.