No Touch Mail (NTM) down
Incident Report for HOALife
Resolved
Our upstream provider has identified the issue to be an infrastructure change that they have reverted. Error rates have abated and we've confirmed NTM deliveries are now operating per normal.

If you received a failed delivery stating "Internal error occurred please contact support@lob com" your letter was will automatically be reprocessed and delivered as expected.
Posted Jun 28, 2022 - 17:23 UTC
Identified
Our upstream mail provider has confirmed an ongoing incident with their services. We advise our customers to avoid using our NTM services until we've confirmed the issue as resolved.
Posted Jun 28, 2022 - 16:40 UTC
Investigating
We are currently investigating the issue with our upstream mail provider.
Posted Jun 28, 2022 - 16:29 UTC
This incident affected: Inspection Dashboard and PDF Rendering.